Icicle-Kit power issue

Got my Icicle Kit today. Only 3 LEDs light up when i turn it on: DS14 (blue by power), 5P0V and 2P5V. Documentations says “Power status LEDs 12P0, 5P0, 2P5V, VDDAUX4, 3P3V, VDD, 1P8, 1P1V_LPDDR4, and VDDA will glow.” That’s not happening. I checked the jumpers twice before attaching the power. I’m using the power supply shipped in the kit. Power cable is fully plugged in. Tried it with and without UART USB attached.

The docs give a suprising amount of detail as to the power rails and voltage regulators. Does that mean this is something I could somehow fix? Somehow I doubt it. The Host USB detects four ttyUSB devices (even with unpowered board), but there is no activity on the UART terminals whatsoever (as expected when the board isn’t properly powered).

Did I do something wrong?

Hey @mikedilger :slightly_smiling_face: it doesn’t sound like you’ve done anything wrong! You should have the 4 power LEDs lighting when you plug it in and flick the switch. I’m really not sure whats gone wrong to cause this.

The quickest and easiest solution for you would be to return the board for a replacement with the distributor you bought it from. Alternatively you can go through the RMA process with our tech support using our portal.

I’m sorry the board hasn’t come up straight away, hopefully you’ll be up and running soon!

Ok I’m doing the RMA thing. Thanks.

Apparently Crowd Supply doesn’t respond to RMA requests. I filled out their RMA form on May 5. Then again on May 14. Still no contact from Crowd Supply. I’m sure there must be some reasonable explanation, but right now it feels like I got scammed.

@mikedilger Ok thats not ideal, our tech support can also help with this if you open a case using our portal: http://soc.microsemi.com/Portal/DPortal.aspx. I’ll ask about crowd supply as I was under the impression they would deal with this. Again I’m sorry this has happened

Thanks Hugh, I’ll go through the Microsemi portal (I see you linked that last time too, I guess I just focused down the Crowd Supply path first).

The possibilities still plague my mind as I try to sleep… maybe they are trying to email me and Fastmail isn’t even putting the emails into my spam folder. Maybe I somehow plugged the USB in upside down (tried that just now, gently, with everything unplugged and I can’t see it fitting that way).

Anyhow I’m sure it will be sorted somehow. One day I will have an actual RISC-V board. One day… [insert wistful dream sequence here]

Thats understandable as you got it through them, we’ve reached out to find out what happened so we can fix the process :slightly_smiling_face:

Even if the USB was upside down it shouldn’t break the board in this way, there are a number of possibilities as you said, if we can get the board back we can do some failure analysis and see what went wrong, and more importantly get you a replacement so you can get started!

Thinking more about it I’m certain I didn’t put the USB in upside down. I distinctly remember four ttyUSB devices with four PuTTY terminals ready and waiting, and then when I switched on the power the first time those devices (and terms) immediately shut down and something showed up in the dmesg (I really wish I saved it). I turned it off, rebooted my linux box, tried again and thereafter it didn’t kick off the USB devices, but didn’t come up.