FTDI JTAG debugger

Are FTDI JTAG debuggers like the diligent HS2 supported for the polar fire development board.

I got the following error while trying to launch debugging session through softconsole
Error: 581 94 mpsse.c:171 open_matching_device(): libusb_get_device_list() failed with LIBUSB_ERROR_OTHER

I tried using openocd 0.11 version, I got the following error
Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway…
Error: mpfs.cpu: IR capture error; saw 0xff not 0x1

I double checked the connections and they are correct. Could anyone please confirm if FTDI probes are supported or any other configurations have to be made to use such probes

You can make your board config file, where you use the interface script of the JTAG dongle you want to use (and maybe setting up a few settings, like JTAG TCK speed etc…) and then you can call the target/microsemi-riscv.cfg script to have complete board script.

Have a look at these board config files:

  • scripts\board\microsemi-olimex-ocd-riscv.cfg
  • scripts\board\microsemi-olimex-tiny-h-riscv.cfg
  • scripts\board\microsemi-olimex-tiny-riscv.cfg

They are using Olimex JTAG debugger dongles with microsemi target config file. You are free to mimic them and make your own and use OpenOCD supported interface (there is a lot of them). They are not tested with Microchip HW, but I would guess that most of them should work without extra hassle.

Don’t forget, you have to make yourself an adapter from whatever JTAG connector you have to Actel FlashPro pinout. From time to time I have seen hobbyists selling small batches of their adapter PCBs. And of course, you can use female to female jumper wires, mind you the shielding will not be good and sensitive to interference from lots of sources. Even lights in your room could induce interference in the signals and you might need to use a much lower JTAG TCK to have a usable connection.

I was unable to get it to work using softconsole and olimex-tiny-h due to the following error.

Error: 568 125 mpsse.c:171 open_matching_device(): libusb_get_device_list() failed with LIBUSB_ERROR_OTHER

But with xPack OpenOCD v0.11.0-4 version it worked. Any ideas on what could be wrong with default softconsole openocd .

If you are on the Windows then you might need to use Zadig to replace the driver. Be careful Zadig is usefull tool, but can mess stuff up too. Use it at your own risk.

Tried Zadig with all the available drivers, it is still failing.

I think the default option in the zadig was good, the WinUSB, and I wouldn’t keep changing them back and fort reclesly (as it can mess up stuff in your OS). Maybe ask Olimex how to use the Zadig.

Don’t know to be honest, SoftConsole OpenOCD is 0.10.0 so maybe in the newer OpenOCD they changed how it is handled. When you say that OpenOCD 0.11 is working for you, then use that instead.